Skocz do zawartości
  • 0
Nalogowy

Problem z modyfikacją Biomes o Plenty na serverze. (1.14)

Pytanie

Nalogowy    0
Napisano (edytowane)

Witam, piszę tutaj ponieważ nigdzie na internecie nie znalazłem rozwiązania mojego problemu odnośnie modyfikacji Biomes o Plenty. Od razu powiem tak, nic co jest napisane na angielskich i polskich forach nie działa. Od razu przejdę do rzeczy i powiem co zrobiłem.

 

Procesor:  Intel Core i7-3820

Ilość ram: 32 GB DDR3

Karta graficzna: GTX 1060 3GB

Wersja sterowników karty graficznej: Najnowsze jakie są:)

Wersja Javy: Version 8 Update 211 

System operacyjny: Win 10

Server robiony pod Hamachi, na własnym kompie:).

1. Forge jest zainstalowany 

Przez przypadek dodałem zaraz zedytuje

2. Modyfikacja BoP została poprawnie zainstalowana PONIEWAŻ działa na trybie Single Player ! ! !

3. Modyfikacja BoP została wrzucona do folderu mods na ".minecraft" oraz do folderu z Minecraft Server Forge/mods jako plik JAR.

4. Ogólnie na singlu działa

Teraz próby i błędy

4. Uwzględnienie w server.properties:

4.1.generator-settings={"landScheme"\:"vanilla","tempScheme"\:"medium_zones","rainScheme"\:"medium_zones","biomeSize"\:"medium","amplitude"\:1.0,"generateBopOre"\:true,"generateBopSoils"\:true,"generateBopTrees"\:true,"generateBopGrasses"\:true,"generateBopFoliage"\:true,"generateBopFlowers"\:true,"generateBopPlants"\:true,"generateBopWaterPlants"\:true,"generateBopMushrooms"\:true,"generateRockFormations"\:true,"generatePoisonIvy"\:false,"generateFlax"\:true,"generateBerryBushes"\:true,"generateThorns"\:true,"generateQuicksand"\:true,"generateLiquidPoison"\:true,"generateHotSprings"\:true,"generateNetherHives"\:true,"generateNetherPlants"\:true,"generateEndFeatures"\:true}

4.2. level-type=customized  oraz level-type=biomesop oraz level-type=biomesofp oraz level-type=biomesoplenty oraz level-type=buffet (nic z tych przykładów nie działało)

Przy czym czasem to wygląda tak jakby chciało a nie mogło, tzn. miałem sytuacje gdzie powinny być duże drzewa zimowe z modyfikacji to był widoczny tylko latający śnieg na wysokości liści tego drzewa oraz ucięty fragment mapy.

Skopiowanie z singla (.minecraft/saves) ustawień z biomes o plenty w ustawieniach generatora świata i wklejenie ich do ustawień na serverze. 

5. Próbowanie zainstalowania moda na różnych wersjach 1.14 w tym: 1.14.4/1.14.3/1.14.2   (inne wersje wcześniejsze niż 1.14.2 nie wchodzą w grę)

6. Edycja oraz stworzenie nowego pliku word.json z parametrami

{

"landScheme": "vanil

"tempScheme": "medium_zones",

"rainScheme": "medium_zones",

"biomeSize": "large",

"amplitude": 1,

"generateBopOre": true,

"generateBopSoils": true,

"generateBopTrees": true,

"generateBopGrasses": true,

"generateBopFoliage": true,

"generateBopFlowers": true,

"generateBopPlants": true,

"generateBopWaterPlants": true,

"generateBopMushrooms": true,

"generateRockFormations": true,

"generatePoisonIvy": false,

"generateBerryBushes": true,

"generateThorns": true,

"generateQuicksand": true,

"generateLiquidPoison": true,

"generateHotSprings": true,

"generateNetherHives": true,

"generateEndFeatures": true,

"mainNoiseScaleX": 80,

"mainNoiseScaleY": 160,

"mainNoiseScaleZ": 80,

"coordinateScale": 684.412,

"heightScale": 684.412,

"upperLimitScale": 512,

"lowerLimitScale": 512

}

7. Przeinstalowanie wersji Forge Client oraz Forge Server.

8. Przeinstalowanie wersji 1.14.3/1.14.4 Biomes o Plenty.

9. Zmienienie w config/biomesoplenty/server.toml ustawień:

#Use the Biomes O' Plenty world type on a dedicated server.
    use_world_type = true             oraz potem dałem               use_world_type = false

Siedzę nad tym już naprawdę długie godziny (co najmniej już 9 a z kolegą wczoraj od 19 do 2 w nocy próbowaliśmy ciągle coś zdziałać)

Staram się sam radzić sobie z problemami jednakże kompletnie nie wiem jak się do tego zabrać, czy w ramach testu mógłby ktoś zobaczyć na swoim kompie jak to wygląda?

Mod(1.14.4): 

Zaloguj lub zarejestruj się aby zobaczyć ten link.

MInecraft Forge(1.14.4) (Po zainstalowaniu wybiera się go w ustawieniach Launchera Minecrafta): 

Zaloguj lub zarejestruj się aby zobaczyć ten link.

Pozdrawiam i proszę o pomoc.

Nałogowy

 

Żeby zaoszczędzić wam szukania to dam źródła z których korzystałem.

Zaloguj lub zarejestruj się aby zobaczyć ten link.

Zaloguj lub zarejestruj się aby zobaczyć ten link.

 (od jakichś tam nowszych wersji nie ma nic w oprócz server.toml w config/biomesoplenty).

Zaloguj lub zarejestruj się aby zobaczyć ten link.

dobra dużo tego było nie chce mi się kopiować wszystkiego w każdym razie przeszukałem wydaje mi się że wszystkie możliwe rozwiązania mojego problemu.

Postaram się wchodzić na bieżąco i informować jeżeli ktoś coś zaproponuje od siebie. Najlepiej to sprawdzić u siebie:( .

 

Edytowane przez Nalogowy
Missclick

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

1 odpowiedź na to pytanie

Rekomendowane odpowiedzi

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Odpowiedz na pytanie...

×   Wklejono zawartość z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

Ładowanie

×
×
  • Dodaj nową pozycję...