Skocz do zawartości
  • 0
TheSzymon240

PermissionsEx! PROBLEM

Pytanie

Siemka!
Mam serwer :P To chyba wiadomo xd Ale permisjie mi nie chcą dziłać...
Mam PermissionsEX i essentials...
Robiłem przed chwilą permisje do danych grup i mam dziwny błąd...
Testowałem czy działają permisje gracza... i wszystkie inne! Prócz Essentiala działały...
Gdy wpisywałem np /help /spawn .itp
To pisało po polsku... Nie masz do tego uprawnień!
A jak z innego pluginu to po angielsku...
Sprawdzałem spacje, ale nie ma żadnych. Nie wiem o co biego bo gdy startuje serwer to nie ma żadnego błędu...
Jak przeładowywuje PEX to jest napisane takie coś:
[22:35:32] [Server thread/INFO]: [PermissionsEx] Permissions file successfully reloaded
[22:35:32] [Server thread/INFO]: Permissions reloaded
 
Nie wiem o co chodzi a serwer miał startować 1 września.|
Proszę o pomoc + dodaje całe permisje...

 

groups:
  default: true
    Gracz:
    permissions:
    - modifyworld.*
    - essentials.afk
    - essentials.afk.auto
    - essentials.back
    - essentials.back.ondeath
    - essentials.delhome
    - essentials.help
    - essentials.helpop
    - essentials.home
    - essentials.home.others
    - essentials.kit
    - essentials.kit.start
    - essentials.list
    - essentials.mail
    - essentials.mail.send
    - essentials.msg
    - essentials.near
    - essentials.rules
    - essentials.sethome
    - essentials.signs.use.enchant
    - essentials.signs.use.free
    - essentials.signs.use.kit
    - essentials.signs.use.warp
    - essentials.spawn
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.tpahere
    - essentials.warp
    - essentials.warp.list
    - essentials.workbench
    - essentials.enderchest
    - authme.login
    - authme.register
    - authme.changepassword
    - authme.unregister
    - authme.logout
    - HiveJumpPads.Jump
    - HiveJumpPads.Trampoline
    - lwc.protect
    - recipecreator.recipes.*
  Admin:
    default: false
    permissions:
    - modifyworld.*
  Vip:
    default: false
    permissions:
    - modifyworld.*
    - essentials.afk
    - essentials.afk.auto
    - essentials.back
    - essentials.back.ondeath
    - essentials.delhome
    - essentials.help
    - essentials.helpop
    - essentials.home
    - essentials.home.others
    - essentials.kit
    - essentials.kit.start
    - essentials.list
    - essentials.mail
    - essentials.mail.send
    - essentials.msg
    - essentials.near
    - essentials.rules
    - essentials.sethome
    - essentials.signs.use.enchant
    - essentials.signs.use.free
    - essentials.signs.use.kit
    - essentials.signs.use.warp
    - essentials.spawn
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.tpahere
    - essentials.warp
    - essentials.warp.list
    - essentials.workbench
    - essentials.enderchest
    - authme.login
    - authme.register
    - authme.changepassword
    - authme.unregister
    - authme.logout
    - HiveJumpPads.Jump
    - HiveJumpPads.Trampoline
    - lwc.protect
    - recipecreator.recipes.*
    - essentials.fly
    - essentials.chat.color
    - essentials.chat.format
    - essentials.msg.color
  Helper:
    default: false
    permissions:
    - modifyworld.*
  YouTuber:
    default: false
    permissions:
    - modifyworld.*
users:
  a27db30c-427f-37c6-904e-3a0a7d035c45:
    group:
    - Admin
    options:
      name: TheSzymon240
  2169dee2-4836-345e-a5e2-bf151a863589:
    group:
    - YouTuber
    options:
      name: PokeSeazard
  cab03d4d-f2a6-3587-956c-b4d6506f112a:
    group:
    - Helper
    options:
      name: MMcrafter24
 

Wiem że Admin .etc nie mają żadnych permisji ale jak dostanie się opa to się ma xd

PROSZĘ O POMOC!

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

3 odpowiedzi na to pytanie

Rekomendowane odpowiedzi

  • 0

Masz błąd. Najpierw powinna być deklaracja grupy "Gracz", a dopiero potem dopisek "default: true". I radzę korzystać z dziedziczenia, bo niepotrzebnie przepisujesz te same uprawnienia wszystkim grupom.

Radzę poczytać

Zaloguj lub zarejestruj się aby zobaczyć ten link.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
  • 0

Masz błąd. Najpierw powinna być deklaracja grupy "Gracz", a dopiero potem dopisek "default: true". I radzę korzystać z dziedziczenia, bo niepotrzebnie przepisujesz te same uprawnienia wszystkim grupom.

Radzę poczytać

Zaloguj lub zarejestruj się aby zobaczyć ten link.

A no fakt... dobra napisze potem czy będzie ok, bo teraz lecę do szkoły :P



Masz błąd. Najpierw powinna być deklaracja grupy "Gracz", a dopiero potem dopisek "default: true". I radzę korzystać z dziedziczenia, bo niepotrzebnie przepisujesz te same uprawnienia wszystkim grupom.

Radzę poczytać

Zaloguj lub zarejestruj się aby zobaczyć ten link.

I ZNOWU! Zmieniłem te miejsce default, a teraz pex w /plugins jest na czerwono! O CO COMON?!?!
Nie ma spacji :(

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.

Zaloguj się tutaj


×